Audi Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
hi guys im new to the forum i have a problem i was driving my 225 tt today and as i changed gear the esp light came on and i lost power and the revs started to hunt meaning revs went up and down then at traffic lights it kept cutting out then the engine light came on then the car ran fine but the lights are still on i have turned it off and left it but the lights still come on please please can some1 help me {will this cost loads?} regards paddy
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
hi guys any1 interested the esp and engine lights were on due to the mass air flow meter playing about and that had to be replaced and that was all down to the fact of a poxy cheep induction kit if i was ever gona put a induction kit back on it would only be the jabba sport one!! it costs about 3 times the amount but thats gona be alot cheeper than replacing the air flow meter every 6 months the filter i had on was a Raid so any of u guys got 1 ???? TAKE IT OFF ASAP or you will have a bill like mine
 

·
Registered
Joined
·
37 Posts
And don't use the Neuspeed CAI (Cold Air Intake) kit either. Placed the Neuspeed CAI on my 00 TT 180 and within 3 weeks I had to replace the Mass Airflow Sensor. Sometimes these CAI manufacturers will load the CAI up with Oil before they ship it to you, when they do this you experience Oil Blow Back that basically coats the MAS with Oil and it is rendered useless.

Stay away from any CAI that Audi doesnt approve and if they approve it you may as well have them install it.
 

·
Registered
Joined
·
1 Posts
Hi Chap just wondered if you managed to find out the problm with your esp light and engine light. I have exactly the same problem, esp light comes on whilst driving then engine cuts out, now my engine light has come on. Do you have the answer.

regards Keith
 
1 - 4 of 4 Posts
Top