Audi Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi
The roof on my cabriolet isn't working at all. It started by folding ok, but the rear deck hatch popped open but didn't rise.....now nothing happens. Does anyone know what the problem might be, or where I can get a circuit diagram, or an alternative to taking into Audi to be fixed?
Regards
Adrian
 

·
Registered
Joined
·
5 Posts
I saw your post earlier - was hoping someone would have offered a solution by now. However:

in my 1998 Cabriolet, there is a nylon string that attaches to either side of the rear interior of the soft top, behind the flap where the rear side windows are. If the string comes loose, as mine did, there will be a tension release on some hidden component. The tension allows movement of the mechanical gizmos which permit the top to be raised (or lowered, I guess).

I didn't have the Audi folks reattach the string - Audi wouldn't do it, anyway. They send that sort of work out to a professional top repair facility. I found a way to tie off the loose end and replace the lost tension. Now, the top will go up and down. It works, at least for the interim. Don't have any idea if this is related to your difficulities.

Jim
 

·
Registered
Joined
·
7 Posts
Hi All,

I have a similar problem.

the rear panel is not popping up to allow the roof to fold away.
I press the button behind the door,and it doesn't appear to do anything.

Normally would this release the rear panel?


thanks for any info..

Dan
 

·
Registered
Joined
·
5 Posts
Originally posted by dancn@May 31 2006, 04:35 AM
The rear panel is not popping up to allow the roof to fold away.
I press the button behind the door,and it doesn't appear to do anything.

Normally would this release the rear panel?

Dan
Dan,

My Cabriolet is a 1998 model. I'm not aware of a "button behind the door" to push. The Owner's Manual provides instructions on how to manually manipulate the top retraction mechanism. More than once, I've raised the top manually without difficulty. Usually, though, the automatic mechanism performs the exercise. I haven't had to resort to a manual process to "fold the roof away". This was the focus of my earlier post. There is some sort of out-of-view mechanism that is held taut by a nylon-type cord for the top retraction process. The cord is attached on the inside to either side of the fabric top, between the fabric and the top's metal framework. My nylon cord became un-attached on one side. I tied it off to replace the tension and that seems to work.

There are two "flap" type covers, one on either side of the rear panel, topside. Lifting the flap exposes a metal lever mechanism that can be moved manually, releasing the locking gears. After release of the gears, the rear panel should be capable of being raised manually.

Hope this was helpful.

Jim
 

·
Registered
Joined
·
3 Posts
I have the same problem the button (which is only on manual roofs as far as I am aware) wont pop the lid, Im going to try to have a root around to see what i can find later on, Ive only just picked up the Cab this morning so not had time to have a fiddle yet, too busy giving it a polish :) if anyone has had the same problem then feel free to let me know to save me the hassle of fault finding
 

·
Registered
Joined
·
3 Posts
My fault was in the wiring loom that is attached around the offside boot hinge the loom has to flex everytime the boot is opened or closed which had split the wires, so a few feet of cable and a soldering iron and the hood lid now pops open as it should, my only problem now is that the roof light on the dash still flashes all the time when the roof is down, is this normal?? or is there a microswitch somewhere that should turn this off when the roof lid is closed properly.
 

·
Registered
Joined
·
7 Posts
An old thread, but may help someone later on a search.

I thought I'd add that I discovered ( ages ago) that a few condtions must be met to allow folding of the roof.
In my case I was new to the car, not spoken to previous owner,
however for a roof problem that has just come about, may not help much..



One my car the roof (manual folding) there is a sequence, and interlocks must be satisfied.

The handbrake switch must be made, handbrake on, this is where I was going wrong ( had it in park only).

So with ign/engine on,, handbrake on,transmission in park (A\T) release top catch from inside,all windows drop automatically to half way position.
Get out, fold roof til rear end is at 90degress, press button behind door, this button then releases the lid of the storage comp for the roof. open lid by hand, fold in roof.

So a non operating rear lid cold be down to a faulty button, or a missing signal from the handbrake switch, or a problem with the lid catch solenoid, or any of the wiring to these,
 

·
Premium Member
Joined
·
1,168 Posts
The lock/unlock signal from boot microswitch can be lost (open circuit).The wiring loom that runs along the osr near the hinge/strut breaks.The outer protective cover is ok but the wiring inside snaps.The pump needs feedback from the micro switch to open.You need to check the micro switch postion at the multiplug connector,near the pump in the osr luggage compartment behind the inner os cover.When you have found the multiplug flick the boot lock with your fingers to closed and then open whilst testing with a multimeter.Dont operate the roof as damage may occur to the lid.
 

·
Registered
Joined
·
1 Posts
zelembac said:
if you did not solve the problem with roof and rear panel , email me I think that I can help you .I had same problem
Hi i have the same problem. My roof stopped working and i had a guy sort it out .He found that it needed bleeding( Hydrolics) This worked for a while but now the rear panel will not lift but it does disengage but will not rise. I have been advise that it may be getting an air lock but seem to have trouble finding someone who can test this. Dont know if you have any suggestions or experience at all or any other ideas. All ideas welcome thanks Graham.........
 

·
Registered
Joined
·
2 Posts
help please

Hi, I saw you post on audiforums.com about a problem you had with the roof compartment of your audi cabriolet not opening. Mine pops up like yours, but then it's like stuck. it sounds like the motor is trying to lift it but nothing happen. I am selling the car and I would have to pay for a mechanic. But I am a girl, i have not idea what to do. Is there a fluid I should top up? do you have any suggestions.. thank you so much
Katia - Florida [email protected]
 

·
Registered
Joined
·
1 Posts
katiaitaly said:
Hi, I saw you post on audiforums.com about a problem you had with the roof compartment of your audi cabriolet not opening. Mine pops up like yours, but then it's like stuck. it sounds like the motor is trying to lift it but nothing happen. I am selling the car and I would have to pay for a mechanic. But I am a girl, i have not idea what to do. Is there a fluid I should top up? do you have any suggestions.. thank you so much
Katia - Florida [email protected]
Hi, im having the same problem, tried topping up the hydraulic fliud but that didnt work for me, if you want to try it its in the boot(trunk) behind the carpet on the right hand side, the fluid plug is located on top of the pump and is brass with a hex head. I got the fliud from my local Audi dealer here in the UK and it cost me £6.69, its the same stuff as used for the power steering fluid
 

·
Registered
Joined
·
1 Posts
Audi cabrio roof problem

I have what sounds like a similar problem with my 95 cabrio, but (after expensive diagnosis at the garage) they said that it was 'probably' a solenoid on the roof pump.
Price for replacement: £2800!

So if anyone has any ideas, I'd be grateful.
 
1 - 15 of 15 Posts
Top