Audi Forums banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi all, hoping that someone can point me in the right direction. I have a 2007 A6 Allroad 3.0tdi and have an issue with the rear brake lights not operating correctly.

I started to have issues with the ESP light coming on along with my ABS light. Noticed that my rear brake lights were intermittently working. After testing a few things I concluded that I needed to replace the brake light switch.

I did this and my brake lights worked as usual. Dash lights remained on. After 5 mins of having the engine running/driving, my brake lights come on and either stay on or flicker. Plugged in an OBD11 scanner and checked the faults. I had one for my brake light switch and one for my ABS control module.

Tried another brake light switch. Had the same results. Checked all fuses, wiring under the dash and everything appeared OK. I decided to send my ABS control module off to ECU testing in Derby and had feedback that the unit was faulty. Had it repaired, plugged back in and bled the brakes, I still have the same issue. Faults won't clear.

I've checked all usual issues, water in ECU box (no issues), replaced the brake light switch again (all genuine), checked harness wiring for corrosion, light units themselves inc connectors, bulbs, changed the clock spring, Sent the unit back to be test under warranty and still have the same issues.

Few points to note:
  • Car has no mods
  • Rear lights are LED and all work
  • Brake lights work fine when my ignition is on
  • Brake lights stay on with the brake light switch disconnected
  • Brake lights stay on with the switch fuse disconnected
 
1 - 1 of 1 Posts
Top