Audi Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
I have had some bizzar problems recently.. first of all i had my oil changed about a month ago, since the i've probably put in an extra quart or so of oil...but the weird thing is, right after i start the car up and drive around for a minute, the oil light will come on, and will keep flashing at me unless i Gun the acceleration for a second, then it will go away until i turn the car off again...what could this be...also there is 10w-30oil in the car, and its getting cold out...could it be too think, and can i thin it out buy adding 5w-30 to it? and just a couple hours ago the check engine light came on (it always used to do that, then go off [the boy who cried wolf])-- Any ideas would be greatly appreciated

Thanks
-Dave
P.S. its a 96 2.8 A6-Quattro
 

·
Registered
Joined
·
137 Posts
Are you seeing any oil drips under the car after you park it for a while? The CEL doesn't supprise me. Seems like any DTC will trip the thing.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #4
Yea, there are a couple drops under the car after its warmed up, but nothing "extream". (its always leaked a little oil when its parked for awhile)...Also its flashing the Red oil lamp at me... does on color mean pressure and one mean level or something?

thanks

EDIT: Also i think it would be a pretty bizzar coincidance if a couple minutes after my oil change, its flashing at me...so dont think its a faulty sensor.
 

·
Premium Member
Joined
·
1,960 Posts
The red oil lamp is bad news - it means you got low oil pressure in the engine !!

I had the light come up on mine and continued driving as the car was running ok and i nearly seized my engine.

It turned out my oil pump had failed due to oil sludge clogging it up ...

Might be worth getting it checked out by mechanic just in case its the start of a more serious problem that could cost a lot of money if you damage your engine...
 

·
Registered
Joined
·
53 Posts
Discussion Starter #7
Unfortuinitly I let my car sit for awhile since i've been uber busy, but tomorrow its scheduled for a checkup, so ill figure it out within a couple days here.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #8
Well, so I talked with my mechanic, and he said that he's almost positive that its not the oil pump itself, because if that goes out, its kinda like your whole engine is worn out--- which is what my friend has told me also... but instead what he thinks it is is the oil pressure senser (which is what you were originally saying before)...and the reason why he thinks its that is because when the car is at idle, no warnings or anything, but when its reved up to a higher rpm, it will flash the oil light. He said something about the car switching the senser when the oil pressure gets to a point, so thats what he is very confidant it is...so im going to have that done next tuesday because they have to order the part. So there you have it ;) hehe.
 

·
Registered
Joined
·
4 Posts
check the stick u might have to much oil in it
that will also turn on the oli lamp ... i had 100ml to much and it turnd on mine
 

·
Registered
Joined
·
3 Posts
Hey I seem to have the same problem except the oil light comes on if im under around 1500-2000 rpms, for example if im in a parking lot in second gear or in traffic. Do you think it might be the same thing? It is pretty annoying lol.
 

·
Registered
Joined
·
4 Posts
maybe

in the audi i had witch was a s4 -94 i had a oil press gauge and thats good to have coz i think the indicator works with both level and press and it warns for both hight and low. So u might have a little bad or slow pump that dont give enugh press on low rpm .... maybe...
 

·
Registered
Joined
·
53 Posts
Discussion Starter #12
Wow, so i took it to my mechanic today, he fixed it in about 30 min, for about 40 bucks... It was the OIL PRESSURE SWITCH, for mine, krutayajiz verywell could be same problem... however you may want to call your mechanic on that one.
 
1 - 12 of 12 Posts
Top