Audi Forums banner

1 - 20 of 42 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Now working in Europe ,where I brought my US car (Audi S8 , 2007) , I have a problem with MMI navigation:
The car being equiped with US MMI DVD (useless here) , I asked Local Eureopean Audi dealer to buy and fit my car with a Europeean Navigation DVD.
He said it might not work in a US model car and he does not want to try to fit European DVD in my car, saying it might damage this DVD (in case this does not work).
I asked my US car dealer who does not seem to know !!!
If somebody knows, "please help"; it would be greatly appreciated.
Thanks for your support.
 

·
Registered
Joined
·
35 Posts
Now working in Europe ,where I brought my US car (Audi S8 , 2007) , I have a problem with MMI navigation:
The car being equiped with US MMI DVD (useless here) , I asked Local Eureopean Audi dealer to buy and fit my car with a Europeean Navigation DVD.
He said it might not work in a US model car and he does not want to try to fit European DVD in my car, saying it might damage this DVD (in case this does not work).
I asked my US car dealer who does not seem to know !!!
If somebody knows, "please help"; it would be greatly appreciated.
Thanks for your support.
DVD in Europe use PAL mode where in North America its a different system NTSC that's why it will not read a european dvd, unless you change the DVD unit then it might work.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Hello,
Thank you for this valuable information ; do you believe Swiss Audi dealers are equiped to proceed to this MMI controller reflash ( to EU software) ? please let me know where this can be done - how long does it take ? what kind of cost ,if you know ...?
Kind regards
 

·
Registered
Joined
·
567 Posts
No, a dealer will not do this for you, unles you know them very well.

US-2-EU MMI conversion:

First of all:

-remove the navigation DVD
-remove all CD's from the CD changer

Then you have to go to the 'hidden menu':

1. open the “hidden menu” on the MMI by pushing first SETUP, en then CAR, keeping them pushed for about 5 seconds.

If this doesn't work, you will need to enable this option by means of VAG COM:

Select 07 - Control Head
Select Adaptation - 10
Select Channel 08
Select Read
Enter new value 1
Select Test
Select Save
Select Done, Go Back
Select Close the controller

Push SETUP & CAR button again, and you should get into the ‘hidden menu’

2. in the ‘hidden menu’ goto MMI>Settings en set “SWDL manuell” and “SWDL ignore Region/VMC' (see picture in previous post) ON

3. insert the EU 5150 file CD in the CD changer on location 1
4. choose in the “hidden menu” for “Start Bootloader”
5. Unit will start update
6. When the update finished: leave the 5150 CD in the changer, and press SETUP & RETURN at the same time and choose “UPDATE”
7. The system will update
8. When finished: remove the 5150 CD from the changer
9. Insert the latest EU DVD in the DVD player
10. Check whether the unit will read the DVD and shows TMC etc.

if so, you are done
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Thank you very much for desciption of the procedure (conversion MMI US 2 EU).
I hope it works...
The Audi car dealer here in Switzerland was not even aware that controller could be reflashed..!
Anyway thanks
Best regards
 

·
Registered
Joined
·
1 Posts
I have the same problem with the navigation of US audi in Europe. Manually inputted address does not stay as a destination. Can you let me know how your update went?
 

·
Registered
Joined
·
7 Posts
Hi!
I have a little problem with my 2004 A8. I’ve added the navigation and I’ve replaced the Bluetooth module (the one with Motorola handset in the armrest) with module which will let me pair my mobile phone via Bluetooth (4E0 910 336).I’ve bought the components on eBay, Sat-Nav in Poland and Bluetooth module in Germany.
Navigation is receiving 0 satellites – I’ve tried two GPS antennas, vag-com can not see any faults there, getaway has been coded, my local Audi dealer said, that the software in my navi unit is even higher than the one they can order at the moment. ???

What could be wrong with it?

When I am trying to use the phone – massage: Your telephone may not be connected or attached properly” appears on the MMI screen. Again the same story with software and vag-com test.

Is it possible, that these units are faulty? Maybe there are some differences between German/Polish and British versions of MMI software?

Please HELP!
 

·
Registered
Joined
·
567 Posts
WHere did you put the GPS antenna for the Nav unit?

There are plenty of duff phone modules on ebay, Audi did a great job of releasing a version which effectively looks up the software and kills itself. Showing telephone not installed is one of the symptoms. I presume you rewired the 46 pin connector to the required 54 pin for the new module.

Software is EU, which covers Europe (which includes the UK)
 

·
Registered
Joined
·
7 Posts
Hi!
I have placed the GPS antenna under the back window, on the shelve (indoor antenna), there was no satellite reception so I’ve bought another one and I’ve left it outside, just to test it and still nothing.

And yes, I have rewired the connectors. I’ve checked it few times and it all looks ok according to the Audi documentation.:mad:
 

·
Registered
Joined
·
7 Posts
Is it possible that my navigation and the telephone module are not working because of the component protection thing? I am wondering, because in both cases VAG-Com shows the same readings…



 

·
Registered
Joined
·
7 Posts
The thing is that there are no faults. I think, I’ve tried everything.
I would appreciate any help. I’ve spend quite a lot of money on these components, and I do not know what to do…
:(
 

·
Registered
Joined
·
11 Posts
Would the MMI reflash work if I have the problem that manually input addresses just disappear? And if so where do I get a EU 5150 file cd? My car is a A5 2009.
 
1 - 20 of 42 Posts
Top