Audi Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
I had that happen on a VW Jetta, so it is probably possible on other cars. They were able to clean the MAF to fix it. I probably used too much oil on the filter or did not let it dry completely.

Laseron2 said:
Has anyone ever herd of the oil used on the K&N air filters damaging a MAF?
 

·
Registered
Joined
·
1,725 Posts
yea i hear alot of that happening also with audis and K&N filters, the heat mets the oil and it gets in the MAF
 

·
Registered
Joined
·
16 Posts
It is possible. Inside the MAF there is a metal plate as a sensor and it is very sensible of all kind of dirty, including oil. I am sure that if the MAF's sensorplate is covered with oil, its functionality is surely damaged.

The sensorplate is heated up and after that, it has a certain resistance. When air flows through the MAF, the air flow cooling down the sensorplate and its resistance be changed. This change of resistance correlates the Mass Air Flow.
 

·
Registered
Joined
·
3 Posts
Can it be cleaned?? I just replaced my mas for 200bux a month ago and it went out again! Changed my airfilter, I was using a K&N that has not been cleaned in 20,000mi so I assume that was the problem.
 

·
Registered
Joined
·
1 Posts
Had a K&N on my A6 for the last 3 years. Have re oiled just once and had no issues. As mentioned don't flood the thing with oil, just enough to coat it lightly. this is sufficient to catch the muck..
 

·
Registered
Joined
·
3 Posts
Had a K&N on my A6 for the last 3 years. Have re oiled just once and had no issues. As mentioned don't flood the thing with oil, just enough to coat it lightly. this is sufficient to catch the muck..
Roger that... Btw instead of replacing my k&N filter I just purchased the recharger kit for 15 bux and cleaned it and reoiled it... In regards to my bad MAS/MAF I used the K&N cleaner and generously sprayed the MAS with it..let it soak for a fivr minute then rinsed it out in cold water... Blow dried it out real good then plugged it back in and it worked
 
1 - 10 of 10 Posts
Top