Audi Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
My 1988 90 (10v) just died and now does not start. The compression is good on all cylinders, spark is there, it is getting fuel up to the fuel distributor so it looks like the fuel pump is good. An Audi mechanic friend had a look and is pretty sure it is the fuel distributor but I rarely have seen one go bad? Could this be the ECU that would control the flow to the injectors at the fuel distributor? Any advice on which part I should buy first and install to remedy the prob? Any and all advice is much appreciated...no fun to have a broken Audi and can't afford to have it towed to the Audi dealer for repair :(
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
Pleeze! Anyone have any ideas? Anything? The police plan on impounding the car in a few days if it is not moved from the road. The plugs look dry and not wet at all, definitely no gas is making into the cylinders, but spark is combusting what was there. The fuel return is sending fuel back after the fuel distributor. Could a sensor be at fault? The archives make mention of cam position sensor, hall sender, check valve, and the fuel pump relay. Any next step? Desperation time....I appreciate any advice.
 

·
Registered
Joined
·
7 Posts
Don't have any great advice on this but if you need any parts I hit mine on a deer and have a new fuel pump but could pull anything you need.
Peter
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Thank you for the nice offer Peter. It turns out the car has thrown a rod. Oddly enough it did not make any noise when it was turning over with the starter. I am quite bummed out. The car is now on ebay for sale as a parts car $222.. It's in Santa Barbara if anyone wants it. Thanks for everbodies response here, much appreciated.
 

Attachments

1 - 4 of 4 Posts
Top