Audi Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have an intermittent fault on my audi 90S auto 1990. The engine dies occasionally when driving. It may restart after five mins or not restart at all. It has been towed to the dealer twice in the last month. when they hop in it starts. It happens when it is warm to hot, and can be really hairy on the freeway or when turning right off Corronation Drive in peak hour.

I have reciently replaced fuel pump, fuel pump relay, fuel filter, distributer cap and roter arm to no avail.

I have read of similar probs on other audi forums but no fixes. Any suggestions?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
It turned out to be the Hall sender. It is now being fixed Aus$300 aprox!!. I get my new VW golf 2litre TDI DSG in about 3 weeks. Desiel- no Hall sender.
 

·
Registered
Joined
·
6 Posts
What do you see on the dashboard when this happens? I also have this problem with a 94 Audi 100S, however it always restarts after a maximum of 1-2 minutes. I get the oil light (although level and pressure are fine), the high pitched alarm that goes along with it, and the automatic transmission gear shift indication flashes all over the place. I'm thinking maybe a faulty oil pressure switch, but I haven't gotten confirmation that this can shut the car down.
 

·
Registered
Joined
·
6 Posts
What does a Hall sender do, and what would be the indication when it fails? Can it only be a problem at high temperatures?
 

·
Registered
Joined
·
2 Posts
I am having the EXACT same problem with my 1994 Audi 100S.
After driving on the highway the "check engine" light comes on,
then after 30-45 sec the engine stops and the oil light comes on.

I cannot find a repairman that knows why this is happening. The dealer in Austin Texas was absolutely useless. They replaced a few parts for $12-25 USD each and said that it was fixed, but it wasn't. The problem usually arises after long periods of driving (~30min or more) or in hot weather.

If ANYONE has any advice or knows how to fix this problem PLEASE let me know.
Also, if I find out I will prompty post it here because now I know I am not alone!
 
1 - 6 of 6 Posts
Top