Audi Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi everyone....I've just changed the Battery on my A4 Avant and am now getting rough idle up and down from 400rpm to 1000rpm and the whole thing cutting out if I brake even normally......any Ideas Im desperate!
 

·
Premium Member
Joined
·
534 Posts
could be a few things... terminals are very sensitive so make sure u got off all the corrosion off them and on the new batter take a metal brush to scratch them up a little bit (the positive and negative)... if that dont work, go for a tune up that should work what yr of car is it?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Kazyee,
It's a 1997...thing is it start fine runs fine but when you brake it cuts out...v dangerous... Just fitted a new battery,so was wondering if its a ecu problem...needs resetting? Trouble is my Audi dealers a money grabbing place so need a no Audi dealer fix!!

Cheers
 

·
Premium Member
Joined
·
534 Posts
k let me ask a few questions first, was it doing this with the old battery? and why did u replace the battery? also... what kind of battery is on it now?
 

·
Premium Member
Joined
·
534 Posts
If your battery died.... ecu's loose their memory when the battery goes dead.
In the memory are things like idle speed, mixture adaptation, etc.
 

·
Premium Member
Joined
·
534 Posts
try cleaning your throttle body... might work, im not really to sure on how to reset your ecu's someone else might no, but clean your throttle body i bet there is a lot in there.
 

·
Premium Member
Joined
·
534 Posts
cool, let me know how you make out. and make sure u do it CAREFULLY
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
Kayzee,
Didn't need to do the throttle clean...got V.A.G and got it recalibrated...what a rubbish system!

Everytime you have a battery prob or total loss of power you need to reset idle engine management.....next cars gonna be a Subru WRX STi !!

Cheers for your imput mate!!

Si
 

·
Premium Member
Joined
·
534 Posts
haha same problem in the sti... plus the sti has a common flaw in their awd but good luck with that :bwekk:
 
1 - 10 of 10 Posts
Top