Audi Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hiv! On my audi a5 2009, when I hit the remote, the driver door won't unlock fully, I need to either open it from inside, or with the key in the keyhole. Any tips what to check ?
 

·
Registered
Joined
·
27 Posts
Hiv! On my audi a5 2009, when I hit the remote, the driver door won't unlock fully, I need to either open it from inside, or with the key in the keyhole. Any tips what to check ?
You need to check the power door lock solenoid. I haven’t had that issue with my Audi, but have had that exact issue with my Maxima.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Ok, should I just take off the door daniel and see if the electric actuator react to the remote ? Thanks 👍
 

·
Registered
Joined
·
27 Posts
Do your other door locks work correctly?
If the other door locks work, then “yes” I would remove the door panel and inspect the actuator. If it seems to react to the remote, but does not fully try and lock it unlocks the door, first check to see that any linkage or connection are not the issue first. If everything else checks out, then you may need to replace the actuator. Looking online, it looks like the door lock actuator and latch assembly are all one piece (Door Latch Assembly). It also shows that this unit is the common repair for issues with intermittent alarm problems & door locking.
I use www.ecstuning.com for all my Audi parts, and they also provide very good customer service for help with parts.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
Thanks. The other door work flawless, i can lock driver door with remote, but not unlock. To unlock i need to use the key. I will open door panel and see if I can see something wrong.
 

·
Registered
Joined
·
27 Posts
Sounds like a plan. I did a quick lookup on ECS Tuning using your vehicle details, and that assembly is quite pricey. The only options they had were OEM Audi parts. Hopefully you can find a simple issue that is easily fixed, once you get the door panel off.
Please keep me posted on what your fix is. Always good info to know.
 

·
Registered
Joined
·
27 Posts
That part number did not show up with the A at the end, but the first part of the number matches.
The part numbers depend on the production date.
Up to the production date 11/02/2009 is 8J1837015B
From the production date 11/02/2009 is 8J1837015F

The part number you mentioned could be correct.
I believe the A on the end of your part could be for the region, since the part I looked up is for USA export vehicles. Shouldn’t be a big difference, but I would use your part number to do a search in your area and see what you can find.
 

·
Registered
Joined
·
27 Posts
That’s perfect!
When I shop ECS Tuning here in the USA for my ‘04 Audi, I can usually find other manufacturer parts, at a price much more reasonable compared to OEM Audi.
 
1 - 13 of 13 Posts
Top