Audi Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
:confused: A6 Allroad 2.5 TDI 2005 - Engine Emission Light On and loss of power

My Engine Emission Warning Light keeps coming on and I get a loss of power this is happening intermittently my local garage says it's properly the Turbo that needs reconditioning or replacing which is expensive. Has anyone had a similar problem I did read somewhere that the accelerator pedal switch can cause a similar problem.

I don't want to replace the Turbo if it's down to a simpler problem
 

·
Registered
Joined
·
1 Posts
Blenk,
I have exactly the same problem, and that's on a 2005 model with a NEW fuel injection pump, suipplied and fitted by Auidi. We've a good garage local to us & he has all the kit to read the fuel pump codes. Ours has an E54 (I think) and an ?86. The E54 is related to a small internal valve that is linked to the idle speed but as it's stuck it will affect power through out the power range. The ?86 is related to an internal Electrical fault.
The garage has cleared the code and we're going to monitor this closely.
My limited experiance on this subject would advise you to get a proper diagnostics done, should not be expensive (except and an Auidi dealership!) but would rule out "Turbo's" and the like....
Good luck! Would be interested to see how you get on!
 

·
Registered
Joined
·
1 Posts
Blenk,

I've just developed the same sort of problem in a 2005 2.5 TDi Allroad. I get loss of power around 2800 / 3000 rpm

What Diagnostic codes are you getting?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Problem Solved

Had Turbo reconditioned and car running ok now was approx. £500 "ouch" also prior to that I had Over Boost Control Solenoid renewed £108 only to find this wasn't the problem so it cost me over £600. Dread to think what a Audi dealership would have charged as I used an independent Audi Specialist garage.

The car is now running as new now so I'm a happy not so rich bunny.
 
1 - 4 of 4 Posts
Top