Audi Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
My indicators have suddenly stopped working - bulbs ok (hazard warning lights still flash). When you operate the indicator stalk, the turn signal on the dashboard flashes once then stops.

has anyone seen this problem before or have any idea what may be the cause?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #2
Did a bit of surfing and it looks like this is a common problem with VW/Audi and that I need to change the combined hazard warning switch/relay.

OK, so next question - best place to buy it apart from audi dealer and is there an equivalent VW item that would fit as these might be easier to source and are probably cheaper!
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
So here's the fix...

Buy a replacement hazard warning switch from your Audi dealer (part no. 8L0 941 509L) who will relieve you of £32 for his trouble.

Arm yourself with a couple of small flat bladed screwdrivers. Remove the trim around the hazard warning switch, pry out the old hazard switch. and replace with new. A 5 minute job with only minor cursing. NB the cables on the connector are quite short so be careful it doesn't fall behind the panel or you may find major cursing is involved.

I suspect the same part is used on other models from the VW stable but couldn't get anyone to admit to that. I had to travel a long distance to an Audi dealer when I have a VW dealer around the corner from me. They would only offer to order the Audi part. Perhaps it would be worth trying Skoda or Seat dealers? - might turn out to be cheaper from them.
 

·
Registered
Joined
·
30 Posts
I had exactly this problem about a month ago. Turned out to be the forward/back axis of the indicator stalk. Something had broken contact when I'd turned off my full-beam, was fine as soon as I swtched full-beams on/off again.

Hope that helps.
 
1 - 4 of 4 Posts
Top