Audi Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
ok, so here's my problem. this problem in my 90 just started occuring today. it's been raining pretty steady all day, and i drove the 90 for about 30 mins and shut her off. when i started up again, she idled very rough and low(about 300-500rpm) and regardless of pressing the gas pedal, the engine speed woudl not increase. after about 15 seconds she just kicked in and was fine all the way home. when i got home and restarted her again about 20 minutes later, the same thing happened, except this time it kicked in ok for only a few seconds, then down to the rough idle again. even while in drive, pressing on the gas pedal will not increase the engine speed at all. later in the day, after trying a couple more times, she will not start at all. she'll crank, and turn over, but as soon as she should idle she dies. if i hold down the gas pedal, the rpms will speraticaly raise and lower, and the engine WILL idle SMOOTHLY with the gas pedal depressed over speeds of 1,500 rpm. as soon as i let go of the pedal she dies.

i've blowdried the inside of the distributor cap, checked every fuse, checked the intake boot, air filter, throttle, etc. and the plugs, and they all seem fine. i've also checked for vacuum leaks, and loose or disconnected wires. i need some suggestions plz. thx for reading.
 

·
Registered
Joined
·
28 Posts
I'm afraid my 1988 audi 90 shares the same problem, a local mechanic told me my idle control valve is going bad... not sure if he was right or not... anybody know how much they are?
 

·
Registered
Joined
·
3 Posts
Knock Sensor

I fought this problem for a long time... Tried changing O2... Temp Sensor,,, I finally broke down and took it to the shop... they replaced the knock sensor and It has been AWESOME.
 
1 - 5 of 5 Posts
Top