Audi Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I've been trying to chase this issue for about 4 months now. it started out as intermediate not starting and i would get the codes p2146 and p2149 (fuel injector group A supply voltage circuit/ open) (fuel injector group B supply voltage circuit/ open) but id be able to get it to start by disconnecting the battery. Eventually it got to the point where the epc light came on, i lost all power and the car died and did not start again. I then went on to replace the fuel injectors and fuel pump relay, still wouldn't start. At this time I was also getting codes for improper voltage to ecu and sometimes no communication to ecu, this turned out to be because the battery was completely fried and once i replaced the battery the codes went away. Then decided to try and do the fuel pressure regulator, the car started and ran but i was then getting codes for fuel pressure regulator performance 2 and low fuel pressure at the rail. I then went on to replacing the high pressure fuel pump, this seemed to fix mostly all the issues the car was having as it drove amazing and pulled very strong with no fuel cuts or anything. I drove it an hour home from my buddies shop and the car died as soon as i got home, epc light came on lost all power and it died. I scanned the codes and I was getting a p0688 (ECM/PCM power relay sense circuit/ open) as well as p2293 (fuel pressure regulator valve (N276) mechanical malfunction) the N276 sensor arrived cracked when i bought it but i was able to super glue it in place (not a permanent fix) so i figured thats why i was getting that code. I decided to replace the fuel pump relay (also the ecu power supply relay) and the car started right up and ran great. I went to take it for a test drive and it ran great with no check engine light for about 15 minutes and then it started to run like !Removed! and then epc lost power and car died. i scanned it and I was then getting the same code again the P0688 but also im getting P0606 (ECM/PCM processor). i suspect my ecu has gone bad or i have some type of wiring issue, or short in the wiring thats causing the ecu power supply relay to go bad. im honestly stumped and do not know what to do with this car anymore, im about ready to give up. Side note: I have a used ecu off another a3 8p but i can not use it as it still has the immobilizer in it and I do not have the proper scan tool to rewrite the immobilizer code. I would like to know what chip inside the ecu is the immobilizer, I looked everywhere and I couldnt find anything on this specific ecu. I provided a picture of the inside of the ecu, if someone can point out which chip is the immobilizer that would be great.
Circuit component Passive circuit component Hardware programmer Electronic component Electronic engineering
 

·
Registered
Joined
·
1 Posts
I've been trying to chase this issue for about 4 months now. it started out as intermediate not starting and i would get the codes p2146 and p2149 (fuel injector group A supply voltage circuit/ open) (fuel injector group B supply voltage circuit/ open) but id be able to get it to start by disconnecting the battery. Eventually it got to the point where the epc light came on, i lost all power and the car died and did not start again. I then went on to replace the fuel injectors and fuel pump relay, still wouldn't start. At this time I was also getting codes for improper voltage to ecu and sometimes no communication to ecu, this turned out to be because the battery was completely fried and once i replaced the battery the codes went away. Then decided to try and do the fuel pressure regulator, the car started and ran but i was then getting codes for fuel pressure regulator performance 2 and low fuel pressure at the rail. I then went on to replacing the high pressure fuel pump, this seemed to fix mostly all the issues the car was having as it drove amazing and pulled very strong with no fuel cuts or anything. I drove it an hour home from my buddies shop and the car died as soon as i got home, epc light came on lost all power and it died. I scanned the codes and I was getting a p0688 (ECM/PCM power relay sense circuit/ open) as well as p2293 (fuel pressure regulator valve (N276) mechanical malfunction) the N276 sensor arrived cracked when i bought it but i was able to super glue it in place (not a permanent fix) so i figured thats why i was getting that code. I decided to replace the fuel pump relay (also the ecu power supply relay) and the car started right up and ran great. I went to take it for a test drive and it ran great with no check engine light for about 15 minutes and then it started to run like !Removed! and then epc lost power and car died. i scanned it and I was then getting the same code again the P0688 but also im getting P0606 (ECM/PCM processor). i suspect my ecu has gone bad or i have some type of wiring issue, or short in the wiring thats causing the ecu power supply relay to go bad. im honestly stumped and do not know what to do with this car anymore, im about ready to give up. Side note: I have a used ecu off another a3 8p but i can not use it as it still has the immobilizer in it and I do not have the proper scan tool to rewrite the immobilizer code. I would like to know what chip inside the ecu is the immobilizer, I looked everywhere and I couldnt find anything on this specific ecu. I provided a picture of the inside of the ecu, if someone can point out which chip is the immobilizer that would be great. View attachment 11802
I joined to help because I was looking for immo. you need to read eeprom and do immo delete with E2PA
I have the p2146 on an 8p and i cannot fix it. Im lost. goodluck w immo
 
1 - 2 of 2 Posts
Top