Audi Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi

I am new here and hope someone can offer some help. My A4 is the 1.9 tdi 130bhp B6 model (2004) with engine code AVF.

When I take my A4 on the motorway occasionally there is a complete loss of power, the car drives as if there is no turbo and really struggles to pick up especially up hill.

Then at the end of the journey when I stop the engine and restart it, it drives fine. There are no error codes displayed either during or after the loss of power.

Any advice would be greatly appreciated.
 

·
Registered
Joined
·
368 Posts
Hmmm... start with the simplest possible answer; the problem could be crappy fuel. Bad/contaminated diesel fuel has sidelined quite few Audi TDI vehicles, so only fill-up with "Top Tier" rated fuels (Top Tier Gasoline) for the next couple of refuelings (at least half of a tank at each refueling) and see if the problem is resolved.

Next up the diagnostic chain would be to replace the fuel filter; this simple act has corrected for quite a few power-loss problems which were intermittent enough not to leave behind any diagnostic fault-codes. If the fuel filter on your Audi has never been replaced, then it's at least an 8-year-old unit and is certainly due for replacement.

Keep in mind that there are a number of fault conditions which are logged in the ECU, but don't necessarily result in the illumination of the "check engine" light (the dreaded, "lightning-bolt to the engine-block" icon.... ;-)

So have the ECU scanned for any stored diagnostic fault-codes. If you don't have a VAG.COM diagnostic scanner, most of the major US auto-parts stores will download and list any stored diagnostic fault-codes for free with a generic OBD-II code-scanner. Interpreting the engine fault-codes is something of a "black art"; you have to consider all observed symptoms as well as all reported fault-codes and correlate this information in order to arrive at a rational prognosis.

Good luck! :cool:
 
1 - 2 of 2 Posts
Top