Audi Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
2001 S4 Avant DTS code diagnosis please

Hi I am a recent second owner of a 21,000 (yep) mile 2001 Avant. I did not notice until we got home that the MIL light was one with the following codes – I have added my notes to the symptoms section:

P0118 – Coolant Temp Circuit High detected

Possible Symptoms
  • Difficulties with starting a cold engine. – don’t think so
  • Starting the engine when engine is warmish or warm, idle rpm immediately is 1200 - 3000 rpm. - no
  • RPM at idle is irregular. – slight fluctuations +/1 100 RPM I say
  • With all engine temperatures seldom idle rpm will vary between 900 - 1000 rpm. – need to check
  • With engine warm (90 °C) the engine temperature suddenly drops (70 °C) and slowly comes back to 90 °C. -no
  • Bad acceleration during warming up. - no
    • Diesel: an indication is extreme long time burning time of the glow indication light.
Possible Causes
  • The electrical signal coming from G62 is too low
  • Wiring and/or connections faulty (short circuit?)
  • Engine Coolant Temperature Sensor (G62) faulty – I think I will replace and have the coolant flush/filled
Possible Solutions
  • Check wiring and connections
  • Check / Replace Engine Coolant Temperature Sensor (G62)
Special Notes
  • In MY 1995-2002 (?) in Europe at VW-cars the G2/G62 had the bad reputation of breaking down often. The default G2/G62 is black and all replacements are green.
P0300 – Random/Multiple Cylinder misfire detected.
16684/P0300/000768 - Random/Multiple Cylinder Misfire Detected

Possible Causes

  • Air Intake System leaking – don’t know
  • Fuel Supply faulty – if they mean fuel, will test. If they mean pump or pressure regulator, don’t know
  • Injector(s) faulty - unknown
  • Ignition Cable(s) and/or Spark Plug(s) faulty –maybe?
  • Ignition Coil(s) faulty –maybe?
  • Exhaust Gas Recirculation (EGR) Valve (N18) stuck/open – could replace
  • Camshaft Position Sensor (G40) faulty – doubt it.
Possible Solutions

  • Check Misfire Recognition
  • Check Air Intake System
  • Check Fuel Supply
  • Check Injector(s) and Injector Sealing
  • Check Ignition Cable(s) and Spark Plug(s) – Will replace plugs, check wire tightness/ add dielectric grease to connections
  • Check Ignition Coil(s)
  • Check Exhaust Gas Recirculation (EGR) Valve (N18) – Will replace
  • Check Camshaft Position Sensor (G40)
Special Notes

  • This DTC indicates that one or multiple cylinders are misfiring, but the ECU fails to identify the cylinder.

àAs you can imagine I am quite angry, we did buy a 3rd party warranty on the car though. In looking at Ross Tech info above he states possible symptoms are:

Coolant – Low coolant level? Will check this one. Bad Temp sensor

Misfires – Coil pack, plugs, plug caps( of course has coil on cap style) or the coil pack. Intake air leak, bad EGR.

Is there anyone who can help me with a VAG test or??? I am in the Madison, Wisconsin area. As the car was gassed up at the dealer in Chicago with who knows what, my first thought is to put 93 in it, add a fuel injector cleaner(NEED RECOMMENDATION ON BRAND/TYPE). Then check coolant levels and possible leaks. Reset OBD. The coolant temp has not gone past the mid way point, and the oil always stays in the 150 zone. I guess the next step would be to replace the plugs – even though I have a hard time believing this in a 22,000 mile car.

Looking for insight and direction on this please.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
B5AUDIS4 said:
For the P0300...check your throttle body boot. It will cause a multitude of error codes to show.
Thank you! I will check the seal on it when I install fresh plugs/air filter. Audi dealer said bad temp sensor too could cause a lean condition in the ignition and mis-fire; ordered that with oring/clip. Can you point me to the location of the sensor on this engine. Any tips? Can you recommend a company for ECU repgrogram too? Thank you much!
 

·
Registered
Joined
·
170 Posts
Hey...There are a ton of good companies out there to reprogram. Are you running with the tiptronic or a 6 speed. If the tip, I've got a MTM stage 1 for sale. As far as where the sensor is located...I'm not sure. I'll look around and see what I can find. You Audi dealer is right though. A bad temp sensor on our engines can cause a lean condition that will cause a misfire. Try to get it fixed ASAP, lean conditions in a car are bad. And, worse in a turbo'd one.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
MTM Stage I

Can you give some more info? How is driveability? I def want something but also want the misses to get good gas mileage as she drives along. I installed a K&N filter (and found 2/4 airbox lid clamps undone(!))and was ready to do the plugs too. Do I need IK20 or IK22s?

If I can get good mileage while not cranking on the car, then I might like to try it!

I have the Tip.
 
1 - 5 of 5 Posts
Top