ABS+ETC lights on (the brake lights are not working) NEED HELP - Audi Forums
General A6, RS6, S6 and 100 Forum (Audi A6 Forum, Audi RS6 Forum, Audi S6 Forum)

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 11-08-2007, 10:38 AM Thread Starter
 
Join Date: Nov 2007
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
ABS+ETC lights on (the brake lights are not working) NEED HELP

I have a 2003 A6, and recently my ABS and ETC lights have been on and the brake lights are not working. I called the dealer and they said to check the fuses - but they are fine.
Does anyone know what the issue may be, and possible expense of fixing it??
THANKS!
ania is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 11-08-2007, 11:51 AM
Premium Member
 
T-sport's Avatar
 
Join Date: Sep 2005
Location: Devon,uk
Posts: 1,960
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
First thing to do is remove rear light covers and check brake light bulbs, could be as simple as blown bulbs as have seen this problem before and it brings up warning lights on dash .. read link ..

http://www.audi-forums.com/b6-forum/...ing-light.html

or other option is brake light switch could be faulty and needs replacing





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by T-sport; 11-08-2007 at 12:01 PM.
T-sport is offline  
post #3 of 8 (permalink) Old 11-08-2007, 12:56 PM Thread Starter
 
Join Date: Nov 2007
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
My bulbs are ok...
ania is offline  
 
post #4 of 8 (permalink) Old 11-08-2007, 02:10 PM
Premium Member
 
a8 tech's Avatar
 
Join Date: Apr 2007
Location: uk
Posts: 1,168
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
brake light switch defective.The switch has three puprposes 1 brake lights 2 engine control unit needs to see the switch on or off and number three the abs/esp needs to see whats going on also from the switch position so replace the switch or check the operation of the switch with a multimeter or vag com.

B6 1.9 TDI AVANT QUATTRO
MODS RS6 wheels, dis + cruise,S line body,Ipod interface,Sline steering wheel, leather interior, Eibach Pro springs.

diagnostic tools vas pc & vcds

If you like your answer then hit the rep button
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
a8 tech is offline  
post #5 of 8 (permalink) Old 11-08-2007, 04:15 PM Thread Starter
 
Join Date: Nov 2007
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Do you know what the cost may be?
ania is offline  
post #6 of 8 (permalink) Old 11-08-2007, 04:47 PM
Premium Member
 
a8 tech's Avatar
 
Join Date: Apr 2007
Location: uk
Posts: 1,168
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
switch £20 ish and to have it checked £50 ish

B6 1.9 TDI AVANT QUATTRO
MODS RS6 wheels, dis + cruise,S line body,Ipod interface,Sline steering wheel, leather interior, Eibach Pro springs.

diagnostic tools vas pc & vcds

If you like your answer then hit the rep button
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
a8 tech is offline  
post #7 of 8 (permalink) Old 10-15-2010, 04:23 AM
Newbie
 
Join Date: Oct 2010
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I just replaced this and all is good. I am no mechanical expert. Just be sure the follow the instructions. When removing the plastic piece under driver. There are 5 bolts. 2 underneath, 1 in the fuse "box" and 2 near the dashboard. The 2 on the dashboard are accessible by "popping" off the piece above the steering wheel. Make sure the Brake light switch locks into place. It was not that bad, only a few hours. The 2 screws on the dashboard had me for a while.
DShaw is offline  
post #8 of 8 (permalink) Old 10-15-2010, 04:24 AM
Newbie
 
Join Date: Oct 2010
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
BTW the part cost me 9.50 euros at the dealer.
DShaw is offline  
Sponsored Links
Advertisement
 
Reply

  Audi Forums > Audi Models > Audi A6, RS6, S6 and 100 Forum > General A6, RS6, S6 and 100 Forum

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Audi Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome