EGR or something else??? - Audi Forums
Forum Rules Please read before posting for the first time.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-14-2019, 09:45 PM Thread Starter
Newbie
 
Join Date: Oct 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
EGR or something else???

I bought Audi A5 3.0 TDI 5 years ago (2010 MY11, coupe) with 42kms on the clock. Two years later, check engine light came up. Took it to the mechanic and he id the fault as “P0402 – EGR insufficient air flow - intermittent”. He did some cleaning and said probably EGR valve but it could be many other things – he told me it could cost thousands of dollars to establish what is the problem. The following 3 years I have been driving the car with this light coming (and going) on a regular basis – more frequently during summer months than during winter. There is no loss of power, the car runs really well; maybe a bit rough in neutral, not sure I can actually gauge. From time to time it ends up revving up in neutral (800 revs vs normal 620) and smells “hot” when I switch it off. “Rev up” sometimes disappears even during the drive – I can feel it when I stop at lights…

I tried using Liqui Molly Diesel Engine intake decarb – no change… I also tried Revive for turbo diesel engine and there was very little (if any) white smoke showing “de-carbonisation” and, from what I saw, the turbo was spotless…

After 5 years of this (105kms) I was tempted to go for EGR delete. However, I decided to change EGR valve instead. My cousin did it for me, so I know it was a thorough job. He only changed the valve – he cleaned the cooler and said it was flowing well. He also cleaned and tested “the flap” (?? not sure what he meant by that). Also, he did manual DPF burn as it was showing 46% …
In any case, you can guess it – the dreaded “check engine” light came up again and it is the same fault code.
Can anybody offer any comment / advice???

milosj
milosj63 is offline  
Sponsored Links
Advertisement
 
Reply

  Audi Forums > Welcome > Forum Rules

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Audi Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome