Slowly loosing coolant and low compression cylinder 4 5 [Archive] - Audi Forums

: Slowly loosing coolant and low compression cylinder 4 5


shalation
12-12-2012, 09:58 AM
Hi There,
I have a 2006 A6 3.2 with 120k miles.

At 70K, it started to slowly loose coolant. Took it to the dealer to diagnose and they ran a pressure test with no leaks found. The only conclusion was for a small leak somewhere and it evaporates.

From time to time, I used to have rough idling then it goes away. Also acceleration seemed to stutter a little bit then goes away. Took it again to the dealer at 75k but the problem didn't occur.

The rough Idling and stutter during acceleration happened more often so I changed the spark plugs and the ignition coil thinking this is the cause.

I was checking it at a mechanic later as nithung has changed and the guy found misfire in cylinder 4 and maybe 5 if I remember correctly. He checked the spark plugs and there was a little oil so he cleaned it.

I've been adding coolant from time to time till now from the 70K incident.

The rough idling increased and now the car stutters and vibrates a lot during acceleration at 120k. From 70k to 120k is less than 1.5 years because of my commute. If I accelerate slowly and maintain a constant speed, it seems to be fine with some vibrations but it seems to be getting worse.

Went again to the dealer and they ran a pressure test and found the following:
1. Low compression in cylinder 4 and 5
2. They put an occilloscope and found some coolant inside

To investigate more, they have to remove the cylinder head and check. They say it could range from a head gasket change, cylinder head change to a complete engine!

Any suggestions on what could be wrong?

My next step is to take the car to my mechanic as he will be cheaper than the dealer.

Thanks!