Random EPC and Check Engine Light OBD2 code p0322 [Archive] - Audi Forums

: Random EPC and Check Engine Light OBD2 code p0322


Mike-A4
10-21-2012, 04:01 AM
Hey guys

About 2 weeks ago my EPC and Check engine light came on. from what i've been reading it's 1 out of 2 things either the speed sensor or crank shaft sensor.

what's been happening to me is the car would idle a little higher then normal when the epc and check engine light come on together. if the epc light comes on alone it runs fine. i've only had one stall so far while in traffic. took 2 starts before the car would actually run. the weird thing is when i clear the codes with my obd2 reader...the car runs fine...and will start fine as well...and i won't get the faults for a good week or so...

just wondering if anyone has ever replaced the speed sensor on a 2002 Audi A4 quattro 3.0 tiptronic before (which would be my guess) as the code i'm getting is P0322 "Speed input circuit - No signal"

ive read alot of forms how to replace them but i can't find it for a 3.0l only the 1.8l. are they in the same location? does any have a picture of what the speed sensor looks like.

I've attached a link with a photo for the website of the sensor can some confirm that this is the speed sensor for this car before i order it?

Thanks guys

heres the link for the speed sensor -

2002 Audi A4 Quattro Vehicle Speed Sensor in Canada - Canada 2002 Audi A4 Quattro Vehicle Speed Sensor (http://www.autopartsway.ca/PartList.cfm?Audi/2002/A4_Quattro/Base/3.0L_V6/allB/Emission_Control/Sensors/Vehicle_Speed_Sensor/pagenum1/tabS)

Mike-A4
11-03-2012, 06:19 PM
Really...no replys at all?