1991 Audi 90 quattro 20V Electrical Problem [Archive] - Audi Forums

: 1991 Audi 90 quattro 20V Electrical Problem


troysherk
10-08-2011, 11:33 PM
Hey everyone,

I have a problem where my driving lights/turn signals/hazard lights come on and stay on. I removed the fuse for the hazard lights, and they turned off, but when I try to use the turn signals, all 4 lights come on again rather than just the side that should come on for the turn signal. I was hoping to pull that fuse as a quick temporary fix since I could probably do without the hazards, but I still need the turn signals to work.

Basically, I think I have a short somewhere. I've had the problem before, and today when I started it, all was well. But then I took it to a car wash, where I'm sure some water got into something it shouldn't have, and the lights have been on ever since (I disconnect the battery to keep it from draining).

Does anyone know where the short might be? I kind of suspect a certain piece, but I'm not sure what it's called. It's a box next to the fuse box which is accessible under the hood partially under the windshield on the driver side. It is finned and has two cannon plugs on top of it. I suspect it as the culprit because the water would have an easy time of getting in there. It looked dry, but if water got in, it would take a while to come back out. I need to know what that piece is called, and it would be nice if someone could provide a wiring diagram or something for the car. I plan to look at a Chilton manual soon at the library, but if someone has the information, that would be helpful too!

Here are a couple of videos I made a few months ago when the problem began:
http://www.youtube.com/watch?v=W2DDFr01k3A

http://www.youtube.com/watch?v=vHShjzX1UwM

Thanks everyone!

troysherk
10-10-2011, 01:10 PM
http://i17.photobucket.com/albums/b91/nintendo52007/IMG_0469.jpg

Here is a picture of the piece I was talking about. It's under the two cannon plugs toward the passenger side from the fuse box.