Transmission wouldn't shift up [Archive] - Audi Forums

: Transmission wouldn't shift up


booliv
04-01-2011, 09:29 PM
Hi, there! I have some transmission problems on my 95 Audi A6 Q. After i drive too fast on curves or push too hard on brakes,or after car was parked on uneven surface- transmission got stuck on low gear and wouldn't shift up. But after i restart the engine the problem GONE! A few years ago i took it to a dealer and flushed transmission fluid.But it didn't resolve the problem...My car has 110 K on it and in great shape and i am not ready to get rid of it yet...Any advice will be greatly appreciated, thanks:)

albenito
04-19-2011, 02:57 AM
Hi guys,

I'm new here to this forum, so excuse any mistakes in my posting!

I have a 1.8 A6 auto with a similar trans problem - won't change out of 1st gear. Fault code reader indicated a speed-sensor fault, but replacement and clearing of fault electronically only solved the prob for a short while.

Prob occurred shortly after gearbox oil-change. Initially could change up through the gears but only at 4-5000 rpm. Re-start did cure the prob temporarily, but problem has returned and this trick no longer works.

Any ideas? Speedometer sensor?

Allan Bennett

booliv
04-21-2011, 05:59 AM
yesterday i added transmission fluid, the level was low...My mechanic was talking about speed sensor too.Haven't driven much since, will see what heppens.

booliv
04-21-2011, 06:09 AM
i think you are having speed sesor problem, mine wouldn't shift up at any rpm