suspension problems [Archive] - Audi Forums

: suspension problems


Arryflatters
02-21-2010, 01:24 PM
Allroad owner now for 20,000 miles. 2.5 tdi FSH. I change all diesel oils every 5k and this one uses no oil at all between changes even ar 160000 miles! --- very high spec car and very good to drive. Here's the "but" and why I'm here.

Towards the end of a months ski trip last winter, during which the Allroad behaved impeccably, coming out of the Aarlberg Tunnel, yellow flashing light indicating suspension problem that Audi had flagged up in Oct 2008 just before I purchased the car. They also highlighted a number of other probs that were total rubbish so I took little notice until the front left went down just as I was turning up to Lech! So I actually drove all the way back with front N/S down. The Suspension Pump was jiggered ( not that Audi's diagnosis had said so, just G291 sensor fault that nobody at Audi would shed any light on). Got a new pump from Arnott's through contact on this Forum. Cheap, and I have some reservations about quality as has been expresed in these pages by others. However it worked but didn't solve the problem, the suspension levels being very erratic and unpredictable in either auto or manual modes. E.g. Front left down, ALL left down, rear right up etc and takes ages to establish a level. I've had it to the Wabco (manufacturer) agents who have been unable to solve anything at all. Nowadays the suspension can stay up at level 2 for days on end then suddenly decides to collapse for no damned reason. I frequently have to stop the car, switch off and reboot perhaps 10 times to get level 2. Its a real nuisance, but overall the car is a *******, so I persevere.
I have finally concluded that the erratic behaviour is down to a faulty valve block ( have never seen this item mentioned in any forum anywhere). The valves are electro-magnetic solenoid type of operation, six in all in a block. 1. From Pump 2. To reservoir 3/4/5/6 one to each wheel. I'm sure that temperature can play a part in the correct operation, as can a bit of debris that could have been introduced during pump change or maintenance? And of course there's always the possibility of poor electrical connection?
Anybody have any views on this? And by the way, Mercedes use the very same pump at about one third of Audi's price..........they have a cheek!!!! Otherwise a great car, amazing in the snow! A very kind man in Germany has supplied full documentation for the suspensions system and I mean FULL, but it is in technical German and beyond my day to day Deutsch ability. Audi UK, and Germany didn't want to know.........they just want to get you to the dealerships who charge you a fortune for incorrect diagnosis and fit repacement parts as opposed to mending the system!