Please HELP I cant link to Diagnostic bus [Archive] - Audi Forums

: Please HELP I cant link to Diagnostic bus


dgpach
02-11-2010, 03:34 PM
Hi, Thanks in advance. I have a 2000 A6 4.2L Quattro (GREAT CAR!) but I cant link to the OBD-II port. I keep getting a linking error with my OBD-II tester. What I've tried is to repeatedly unplug a module and try to establish a link. If unsuccessful, I plug it back in and try another. So far I tried the TCM, Locking control molule, ABS module, Radio head unit and the Climate control. I even swapped out the Engine ECU, but still no luck. The OBD-II tester is a mid range unit and works on my other A4 Audi and Ford. Any thoughts on what could be causing this? I can't pass Calif SMOG unless the tech can connect to the CanBUS which means I can't have the fun of driving this car....

a8 tech
02-11-2010, 03:38 PM
your vehicle does not support canbus diag protocol, it supports K wire.You need either vcds or the adapter to convert k wire protocol.
Hope that makes sense

dgpach
02-11-2010, 03:49 PM
Guess I'm using the wrong terminology. The problem is that the OBD tester wont communicate with the Diag port, so I can't review any trouble codes and the SMOG tech can't verify the readiness status which is a requirement for Calif SMOG.
Thanks

a8 tech
02-11-2010, 03:56 PM
Ok if you cant connect to any control unit then you must check the obd connection on the vehicle.Check the Kwire from the obd port to the engine ecu for short to earth, short to positive or open circuit.
Run a dummy wire direct to the ecu and reconnect your tester to establish comms

dgpach
02-11-2010, 05:25 PM
Thanks, I'll check this out, but I was led to believe this problem was module related and not the interconnect wiring. About 4 months ago my Audi Indy couldn't link his VagCom and said the ABS module was shorting out. He changed it and said it was then able to link, but there was a pending issue (he described as an intermittent short) in the convience / comfort system? Does this make any sense?

a8 tech
02-12-2010, 11:45 AM
disconnect the abs and try to access address 01