How to reset service indicator - Audi Forums
Audi Forum Audi Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   Audi Forums > Audi Models > Audi A4, RS4 and S4 Forum > General A4, RS4, and S4 Discussion
Register Home Forums Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

Audi-Forums.com is the premier Audi Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-14-2007, 02:09 PM   #1 (permalink)
Newbie
 
Join Date: Jul 2007
Posts: 9
Gallery: (0)
Busa1400 is on a distinguished road
Default How to reset service indicator

I have a 54 reg A4 and the service indicator needs resetting, any ideas.

Cheers

mick
Busa1400 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-14-2007, 02:30 PM   #2 (permalink)
Premium Member
 
T-sport's Avatar
 
Join Date: Sep 2005
Location: Devon,uk
Posts: 1,960
Gallery: (0)
T-sport is an unknown quantity at this point
Default

Have a read of this thread http://www.audi-forums.com/audi-a3-r...=service+light
__________________
T-sport is offline   Reply With Quote
Old 09-14-2007, 09:23 PM   #3 (permalink)
Newbie
 
Join Date: Jul 2007
Posts: 9
Gallery: (0)
Busa1400 is on a distinguished road
Default

Thanks alot mate, spot on
Busa1400 is offline   Reply With Quote
Old 09-15-2007, 04:51 AM   #4 (permalink)
Newbie
 
Join Date: Jul 2007
Posts: 7
Gallery: (0)
CraigJ is on a distinguished road
Default

is this for newer a4's just tried it on my 96 2.6se with no joy. Anyone know how to reset on older a4's?
CraigJ is offline   Reply With Quote
Old 09-16-2007, 03:33 AM   #5 (permalink)
Member
 
boycarp's Avatar
 
Join Date: Dec 2006
Location: Ulleskelf (inbetween Leeds and York)
Posts: 32
Gallery: (0)
boycarp is on a distinguished road
Default

worked on my 99 a4
__________________
Carpo aka Jayson
boycarp is offline   Reply With Quote
Old 06-16-2009, 03:11 AM   #6 (permalink)
Newbie
 
Join Date: May 2009
Location: Cape Town
Posts: 3
Gallery: (0)
Calmguy is on a distinguished road
Default

Doesnt work on my 2002 A3, but I think its cause I dont have an onboard computer. My service indicator just says "SERVICE !". Any idea how to reset it?

I always have done my own services and my Jetta and Golf I previously had was easy to reset (press hold right, ignition on, turn left to the right(or left) ). They had on board computers though. This audi doesnt.
Calmguy is offline   Reply With Quote
Old 06-24-2010, 10:44 AM   #7 (permalink)
Senior
 
JasonS4's Avatar
 
Join Date: Feb 2010
Posts: 155
Gallery: (13)
JasonS4 is on a distinguished road
Default Reseting Audi A4 Service Indicator - How To Reset The "Service!" Warning

Should work on Audi A4 and S4, B6 and B7 - 2002 2003 2004 2005 2006 2007 2008

I did this on a 2002 B6 Audi A4 3.0L Quattro for reference.

To reset the "SERVICE!" warning indicator ignition must be "off".

Hold in the wrench button on instrument cluster, and at the same time turn your key forward (without starting). While still holding the "wrench" button in, press the "0,0" button and hold until the "SERVICE!" notification clears (about 2-3 seconds).

"Service!" Indicator Reset Procedure/Service Indicator Reset Complete!
JasonS4 is offline   Reply With Quote
Old 06-24-2010, 11:27 AM   #8 (permalink)
oki
Newbie
 
oki's Avatar
 
Join Date: Jun 2010
Posts: 24
Gallery: (0)
oki is on a distinguished road
Default

I did this on mine and it got rid of the service indicator, but now it just shows the following:

Service In
Days ----
Miels ----

Any ideas of when it is going to show up with some numbers instead of ---????
__________________

2006 A4 Quattro 2.0T all stock

Last edited by oki; 06-24-2010 at 11:29 AM.
oki is offline   Reply With Quote
Old 06-24-2010, 11:32 AM   #9 (permalink)
Senior
 
JasonS4's Avatar
 
Join Date: Feb 2010
Posts: 155
Gallery: (13)
JasonS4 is on a distinguished road
Default

As you drive it will start to calculate. That is normal ... that is what it is supposed to do.

Last edited by JasonS4; 06-24-2010 at 11:36 AM.
JasonS4 is offline   Reply With Quote
Old 02-11-2011, 05:33 AM   #10 (permalink)
Newbie
 
Join Date: Feb 2011
Posts: 1
Gallery: (0)
kwils1810 is on a distinguished road
Default

Thanks for the advice, your process did not work on my 2003 Audi A4 1.9 Tdi avant, I played around with the cluster of buttons on the electronic dash and found a system that worked....
1) Press in the button with the spanner on
2) turn ignition on so dash lights up but do not start the engine
3) press the 0.0 (odometer restet) button
display should now read service due in ........MILES
........DAYS

hope this helps others needing this advice

Kind Regards
kwils1810 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Audi Forums > Audi Models > Audi A4, RS4 and S4 Forum > General A4, RS4, and S4 Discussion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 04:38 AM.




Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO 3.3.2