ESP Indicator Light / Brake Sensor Switch - Audi Forums
Audi Forum Audi Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   Audi Forums > Audi Models > Audi A4, RS4 and S4 Forum > B6 Forum
Register Home Forums Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto Escrow

B6 Forum 2002-2005 Audi A4 & Audi A4 Cabriolet / 2004 Audi S4. (Audi A4 Forum, Audi S4 Forum, Audi RS4 Forum)

Audi-Forums.com is the premier Audi Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-09-2011, 04:27 PM   #1 (permalink)
Newbie
 
Join Date: Nov 2010
Posts: 13
Gallery: (0)
audi2003a4 is on a distinguished road
Default ESP Indicator Light / Brake Sensor Switch

My 2003 's ESP and Check Engine Light are both on. Several posters have sworn that the Brake Sensor switch is the culprit. Others post that the Mass Airflow Sensor or switch is the one.

Logic seems to side with brakes since it relates to ESP. But then since the car shifts into Drive it seems the sensor switch maybe working (remember the car won't shift unless you cover the brake so the car knows the brake is on).

I've had the brakes checked out to make sure the car is safe and they are fine.

So when you fixed the ESP light was the "Check Engine Light" also on ?
Was it the Brake Sensor Switch?
Is there a way to reset the warning lights with any key / button sequence ?

Anyone ? Bueller ?
audi2003a4 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-13-2011, 03:28 AM   #2 (permalink)
Newbie
 
Join Date: Aug 2011
Posts: 3
Gallery: (0)
toka is on a distinguished road
Default

Quote:
Originally Posted by audi2003a4 View Post
My 2003 's ESP and Check Engine Light are both on. Several posters have sworn that the Brake Sensor switch is the culprit. Others post that the Mass Airflow Sensor or switch is the one.

Logic seems to side with brakes since it relates to ESP. But then since the car shifts into Drive it seems the sensor switch maybe working (remember the car won't shift unless you cover the brake so the car knows the brake is on).

I've had the brakes checked out to make sure the car is safe and they are fine.

So when you fixed the ESP light was the "Check Engine Light" also on ?
Was it the Brake Sensor Switch?
Is there a way to reset the warning lights with any key / button sequence ?

Anyone ? Bueller ?
Have you done the 'Plenum grommet' mod?

Was it raining when you had the problem?
toka is offline   Reply With Quote
Old 08-13-2011, 02:07 PM   #3 (permalink)
Newbie
 
Join Date: Nov 2010
Posts: 13
Gallery: (0)
audi2003a4 is on a distinguished road
Default

Quote:
Originally Posted by toka View Post
Have you done the 'Plenum grommet' mod?

Was it raining when you had the problem?
No "plenum grommet mod". Not sure if you think that causes or cures the issue.

No rain either...dry as a bone here.

The only clue I have (since the car is running and braking fine (though not sure if ABS is working - need to get it out in a parking lot to see) is that when I deleted the P0102 error code the CEL light went out for several minutes while the ESP light stayed lit.

Thanks for asking and any ideas. I ordered a brake sensor switch (only $ 10 + shipping) and will post back next week when that arrives.
audi2003a4 is offline   Reply With Quote
Old 08-13-2011, 04:42 PM   #4 (permalink)
Newbie
 
Join Date: Aug 2011
Posts: 3
Gallery: (0)
toka is on a distinguished road
Default

Quote:
Originally Posted by audi2003a4 View Post
No "plenum grommet mod". Not sure if you think that causes or cures the issue.

No rain either...dry as a bone here.

The only clue I have (since the car is running and braking fine (though not sure if ABS is working - need to get it out in a parking lot to see) is that when I deleted the P0102 error code the CEL light went out for several minutes while the ESP light stayed lit.

Thanks for asking and any ideas. I ordered a brake sensor switch (only $ 10 + shipping) and will post back next week when that arrives.
The plenum area has 2 grommets to let out the water which gathers there (it drains from the windscreen area into it). But the grommets get clogged with crud and the water stays in there. The ECU and break cylinder is in there, and when water builds up it WILL cause all sorts of issues including ESP errors and limp mode.

If you have a B6 model, you will almost certainly suffer with this.
toka is offline   Reply With Quote
Old 08-20-2011, 12:00 PM   #5 (permalink)
Newbie
 
Join Date: Nov 2010
Posts: 13
Gallery: (0)
audi2003a4 is on a distinguished road
Default

Quote:
Originally Posted by audi2003a4 View Post
No "plenum grommet mod". Not sure if you think that causes or cures the issue.

No rain either...dry as a bone here.

The only clue I have (since the car is running and braking fine (though not sure if ABS is working - need to get it out in a parking lot to see) is that when I deleted the P0102 error code the CEL light went out for several minutes while the ESP light stayed lit.

Thanks for asking and any ideas. I ordered a brake sensor switch (only $ 10 + shipping) and will post back next week when that arrives.
I replaced by brake light switch which is quite simply to do. That however didn't get the lights out. The ABS does work. ESP light came back on after the brake sensor switch replacement and deleting error P0102 (almost immdediate). CEL came back on after several minutes.

Again the odd thing is that I notice no symptom other than those two lights. Parts store dude said in the hot weather you might be fine if the MAF was bad.
So to recap it seems brake sensor switch did not cause ESP light. The error code (p0102 Mass AIr Flow) and idiot light (ESP) seem to conflict. A bug in Audi's OBDI maybe.
audi2003a4 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Audi Forums > Audi Models > Audi A4, RS4 and S4 Forum > B6 Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 05:16 AM.




Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO 3.3.2