Car jerks and shake when accelerating. Check Engine Light on...please help. - Audi Forums
B6 Forum 2002-2005 Audi A4 & Audi A4 Cabriolet / 2004 Audi S4. (Audi A4 Forum, Audi S4 Forum, Audi RS4 Forum)

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-02-2011, 07:08 PM Thread Starter
Newbie
 
Join Date: Feb 2011
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Car jerks and shake when accelerating. Check Engine Light on...please help.

I have an 04 A4 with 85k miles on it. Never had a problem with it. Today, while driving home, car starts shaking vigorously when stepping on the gas, and check engine light appears. When in neutral, its fine. At idle, there is a few jerks. I pulled over and checked out the engine, but didnt see anything. Got back in and drove another 2 miles home slowly. Luckily I made it home.

Does anyone had a similar issue? I'm thinking its time for a tuneup. I'm at school and work all day so don't have time to do much research. Someone help with any advice on what it could be before I take it in the shop please!

Thanks in advance.
blahblah is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-03-2011, 08:56 AM
Premium Member
 
docurley's Avatar
 
Join Date: Sep 2006
Location: London
Posts: 1,528
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I would say a coil-pack or MAF.

First of while the car is running unplug the wire to the MAF, if nothing changes then thats OK.

Next remove the engine cover and unplug one of the coil-pack leads and see if anything changes, if nothing does when you remove one then theres you problem.

You must unplug it and reconnect it one at a time to find which one is knackered.

If your in the UK the main dealer tends to be the cheapest for coil-packs at around £30 each


04 Audi A4 B6 1.8TQ S-Line 190bhp 6 Speed Duel SMIC
Milltek Exhaust|VMR boost Gauge|SP51 K04-15 Outlaw (K04-23+)|Samco Sport DV|034 Sport CAT (15bhp over stock)|TT MAF| 380 inj| Autobahn88 TIP|
To be fitted: B7 RS4 F-Brakes|B5 RS4 R-Brakes|SB Stage4 Clutch|
docurley is offline  
post #3 of 3 (permalink) Old 02-10-2011, 08:37 PM
Newbie
 
Join Date: Feb 2011
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Same thing happened to me. I had 2 cylinders misfiring.
icy_m is offline  
Sponsored Links
Advertisement
 
Reply

  Audi Forums > Audi Models > Audi A4, RS4 and S4 Forum > B6 Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Audi Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome