Is P0421 a persistant code? - Audi Forums
B5 Forum 1996-2001.5 Audi A4 / 2000-2002 Audi S4 & Audi RS4. (Audi A4 Forum, Audi S4 Forum, Audi RS4 Forum)

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-26-2010, 02:44 PM Thread Starter
Newbie
 
Join Date: Nov 2009
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Cool Is P0421 a persistant code?

My s4 keeps turning on the servie engine light with a p0421 code. I have captured the live data for the O2 sensors and graphed them and found the lines to run paralell. (Leading me to believe both O2 sensors are operating pretty close to the same and that it is not an O2 Sensor issue, but rather a problem with the cat.) My question is, will the light eventually go off on it's own after a period of time? I know my A8 will throw occasional codes but eventually the service light goes out even though the codes are still present. I haven't driven the car long enough with the light on to see if it will go out on it's own.

Any advice appreciated.
ayjay1975 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-28-2010, 12:36 PM
Senior
 
Join Date: Apr 2010
Posts: 220
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Warm up catylist below efficiency - that should not go out unless the problem does not come back. Likely, you're looking at a new catalytic converter. Any other cat related codes? How frequently does the error come back?
Pete@ecstuning is offline  
post #3 of 5 (permalink) Old 06-01-2010, 08:15 AM Thread Starter
Newbie
 
Join Date: Nov 2009
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Thank you for the reply. I have only had the car for a few months and that code has come up 2 times. No other codes at this time. Currently my ecuis at APR having a look over. It want down and would no longer run the car. I am running a used stock ECU at the moment and the problem hasn't come back YET. I am wondering if the tolerances set on my chipped ecu were too tight?

I see you work for ESC tuning... I lost the little ESC logo that fits inthe top on my short throw shifter. Any ideas on how to get a replacement? (It looks silly without it)

Thanks again!
ayjay1975 is offline  
post #4 of 5 (permalink) Old 06-01-2010, 02:11 PM
Senior
 
Join Date: Apr 2010
Posts: 220
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Do you have a part number for the shifter you've got from us?
Pete@ecstuning is offline  
post #5 of 5 (permalink) Old 06-01-2010, 10:23 PM
Full Member
 
Join Date: Jul 2009
Location: lowell,mass
Posts: 128
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
0421/0431 + secondary air

I know thats a hose throwing these codes. But i'm ready to up grade any way. Price cats/dp's i'm in the boston area ??
pauly b is offline  
Sponsored Links
Advertisement
 
Reply

  Audi Forums > Audi Models > Audi A4, RS4 and S4 Forum > B5 Forum

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Audi Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome