Reset Procedure for the A4/A6 Service Light - Audi Forums
Audi Forum Audi Forum

» Auto Insurance

» Featured Product
» Wheel & Tire Center

Go Back   Audi Forums > Audi Models > Audi A4, RS4 and S4 Forum > B5 Forum
Register Home Forums Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto Escrow

B5 Forum 1996-2001.5 Audi A4 / 2000-2002 Audi S4 & Audi RS4. (Audi A4 Forum, Audi S4 Forum, Audi RS4 Forum)

Audi-Forums.com is the premier Audi Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-01-2006, 08:28 AM   #1 (permalink)
Member
 
oziaudi's Avatar
 
Join Date: Jun 2006
Location: Gold Coast, Australia
Posts: 43
Gallery: (0)
oziaudi is on a distinguished road
Default Reset Procedure for the A4/A6 Service Light

Hi Guy's
This should help a few of you.
Regard's Addam
Audi A4 & A6 Service light reset
Turn off the ignition
Press and hold the button on the left hand side of the display while turning the ignition on.
Service oil will be displayed.
Pull out the button on the right side of the display until the service prompt is cleared.
The display should now read ---

If the above procedure does not work, outlined below is a alternative procedure.

With the ignition off, push the right button.
Turn the ignition on and then pull the left button.
This should clear the warning message
oziaudi is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-05-2006, 10:15 AM   #2 (permalink)
Newbie
 
Join Date: Jun 2006
Posts: 19
Gallery: (0)
tesh is an unknown quantity at this point
Default

It doesn't work for me. ('97 A4 Avant 1.8)
The first procedure you wrote is not good for me because if I pull (cannot be pushed) the LEFT button (from the clock) - it adjusts the clock even without the key inserted.
The alternative procedure doesn't work. I have tried to switch the key to ON position (when all the lights turn on), but without starting the engine. Do I have to start the engine?
What I did:
I pressed the right button (the one close to the km counter display). I turn the key to ON position, and in the trip km counter the text 'IN 1' appears (I understood this means Inspection Required). I then tried pulling the left button, but nothing happened. The text dissapeared as usually after a few seconds, and appeares again at the next start.
tesh is offline   Reply With Quote
Old 07-05-2006, 06:28 PM   #3 (permalink)
Member
 
oziaudi's Avatar
 
Join Date: Jun 2006
Location: Gold Coast, Australia
Posts: 43
Gallery: (0)
oziaudi is on a distinguished road
Default

Hi Tesh
Don't start the car just turn the ignition to on.
Try that
Addam
oziaudi is offline   Reply With Quote
Old 06-06-2007, 03:39 AM   #4 (permalink)
Newbie
 
Join Date: Dec 2006
Location: Berkshire
Posts: 9
Gallery: (0)
Spot30 is on a distinguished road
Default

Sorry to bring this thread back but for some reason this doesn't work for me.

I have an A4 1.9 TDI 110 1998. The first procedure doesn't work and simply adjusts the clock. The alternative procedure works to the point where I can change oil service to ---. However my display is flashing service Insp at me and this procedure won't reset that as everytime I turn the car back on it comes back.

Any help would be appreciated.

Anthony
Spot30 is offline   Reply With Quote
Old 10-15-2007, 12:44 PM   #5 (permalink)
Newbie
 
Join Date: Mar 2007
Location: UK Lancing West Sussex
Posts: 6
Gallery: (0)
Dinger123 is on a distinguished road
Default

Hi

Thanks for posting this information - I have had service insp flashing for the last couple of weeks... so finally got round to changing the oil & filter this weekend ... It took me 5 mins of sitting in the car turning ignition on and off but it cleared it for me ... the more you try the more obvious it gets... Hold right hand button then turn on ignition... then pressing right hand button swops between OIL & INSP pulling left hand button clears display to ---- and then when you turn ignition off and on its clear! Woo hoo!!

Many Thanks
Dinger
__________________
Audi A4 2.4SE V6 Manual 1998
Dinger123 is offline   Reply With Quote
Old 07-23-2008, 12:36 AM   #6 (permalink)
Newbie
 
Join Date: Jul 2008
Posts: 2
Gallery: (0)
andraqyen is on a distinguished road
Default

Quote:
Originally Posted by oziaudi View Post
Hi Guy's
This should help a few of you.
Regard's Addam
Audi A4 & A6 Service light reset
Turn off the ignition
Press and hold the button on the left hand side of the display while turning the ignition on.
Service oil will be displayed.
Pull out the button on the right side of the display until the service prompt is cleared.
The display should now read ---

If the above procedure does not work, outlined below is a alternative procedure.

With the ignition off, push the right button.
Turn the ignition on and then pull the left button.
This should clear the warning message
Dear Brother,

My audi A4 2.6 year 1998, i've already try ur way, but its not working , in my dashboard there is 2 button :

1. left button is for the clock ( quartz not digital ) and can only be pulled, cannot push the button.

2. right button is for reseting the KM, and can only be pushed, cannot be pulled.

can you find me the solution bro ? I really˛ need help bro....thanx for ur attention.

rgds,
Caesarandra
andraqyen is offline   Reply With Quote
Old 05-11-2011, 01:08 PM   #7 (permalink)
Newbie
 
Join Date: Feb 2010
Posts: 3
Gallery: (0)
gilberti69 is on a distinguished road
Default This is how I did it...

The above procedure didn't work for me on my '96 A6 TDI Avant but gave me enough of an idea to figure out one that would:

1 hold right button and turn on ignition - display shows 'OIL' - release right button

2 pull left button until display shows '----'

3 press right button again until display shows 'INSP'

4 pull left button until display shows '----'

Sorted!

It appears there is an OIL AND INSP counter

Hope this helps people.
gilberti69 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Audi Forums > Audi Models > Audi A4, RS4 and S4 Forum > B5 Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 09:44 PM.




Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO 3.3.2