Audi 80 2.6 Auto shift problem - Audi Forums
Audi 80, 90 & Coupe Forum Discussion area for every generation Audi 80, Audi 90 and Audi Coupe. (Audi 80 Forum, Audi 90 Forum, Audi Coupe Forum)

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-21-2013, 03:38 PM Thread Starter
Newbie
 
Join Date: Mar 2011
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Smile Audi 80 2.6 Auto shift problem

Had a problem with my auto transmission which was shifting up at very high revs (over 4000). The gears would hold until the high revs were reached and not change otherwise.
I tried changing the oil and filter and ensured the level was right all to no avail.

I then thought a little more and swapped out the TCM (transmission control unit).
Our cars being quite old have a separate ECU for the Engine and Transmission.

Low and behold the new TCM has fixed the fault.

I checked out the old TCM on a parts car I have ( still a runner) and the same behaviour existed.

Anyhow I hope this helps somebody out. The forum has been great to me in the past and I thought I would share my knowledge.

Happy motoring.
alex63 is offline  
Sponsored Links
Advertisement
 
Reply

  Audi Forums > Audi Models > Audi 80, 90 & Coupe Forum

Quick Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome